Since the old Facebook API is deprecated and the request for permissions from Irssibook to Facebook did not work anymore I updated irssibook to use the latest Facebook GRAPH API with their OAUTH 2.0 integration.

This brings some changes:

  • WWW::Facebook::API is dropped since it does not use the GRAPH API
  • LWP::UserAgent is now a dependency
  • JSON and JSON::XS are now dependencies
  • The ‘-clear’ feature is dropped, but will be implemented when I find some more time to investigate the GRAPH API

To update to the newest version of Irssibook have a look on Github.

/dev/out